Error when starting debugging.

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

danieluser
Posts: 1
Joined: Thu Apr 04, 2019 6:19 pm

Error when starting debugging.

Postby danieluser » Thu Apr 04, 2019 6:33 pm

Hi!

I have just installed atollic studio for STM32 (latest version 9.3.0) on latest Ubuntu (lauched on virtualbox). I have generated the code in CubeMX and imported to atollic.
In the next step I have write some code to blink the LED and I've build the project. Everything was fine.
After that I have clicked Run->Debug option. Atollic asked me to upgrade the firmware in ST-Link so I do that. I'm using the NUCLEO-F334R8 board.

Now I want to run my program so I'm clicking Run->Debug again but I'm getting the error:

STMicroelectronics ST-LINK GDB server. Version 5.1.0
Copyright (c) 2018, STMicroelectronics. All rights reserved.

Starting server with the following options:
Persistent Mode : Disabled
Logging Level : 1
Listen Port Number : 61234
Status Refresh Delay : 15s
Verbose Mode : Disabled
SWD Debug : Enabled

ST-Link enumeration failed

Error in initializing ST-LINK device.
Reason: ST-LINK DLL error.


I was trying some regonfiguration but without result. Maybe somebody can help me please?

Daniel

BlueSea
Posts: 1
Joined: Mon Apr 08, 2019 4:30 am

Re: Error when starting debugging.

Postby BlueSea » Mon Apr 08, 2019 4:35 am

I also found the same problem.

I tried to connect the STM32L476G-DISCO board and start debugging.

ST-LINK firmware update is requested and has been updated.

And you cannot start debugging due to the same error as the writer. :cry:

It's thought of as a bug in a program.

cljdonato
Posts: 2
Joined: Fri May 17, 2019 11:33 pm

Re: Error when starting debugging.

Postby cljdonato » Fri May 17, 2019 11:44 pm

I'm also having the same problem.

When I use the NUCLEO-F030R8 demoboard I can debug the code without errors. However, with S-TLINK / V3 it does not work.


Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 2 guests