ST-Link DLL error uploading from Ubuntu 16.0.4 LTE

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

emintz
Posts: 12
Joined: Mon Jan 15, 2018 11:22 pm

ST-Link DLL error uploading from Ubuntu 16.0.4 LTE

Postby emintz » Sun Mar 04, 2018 9:11 pm

Binary installation from TrueStudio fails for my Nucleo-F767ZI. /etc/udev/rules.d contains:

11-android.rules 49-stlinkv2-1.rules 49-stlinkv2.rules 55-pemicro.rules 56-hpmud.rules 80-hasp.rules 99-jlink.rules

(I have the Android SDK installed as well). Can someone please advise? Thank you very much in advance.

Your biggest fan,
Eric Mintz

The error message is:

Atollic TrueSTUDIO gdbserver for ST-Link. Version 4.2.0 (LINUX64 2018-01-16 10:57:14 15656)
Copyright (c) 2018, STMicroelectronics. All rights reserved.


Starting server with the following options:
Persistant Mode : Disabled
LogFile Name : debug_log.txt
Logging Level : 1
Listen Port Number : 61234
Status Refresh Delay : 15s
Verbose Mode : Disabled
SWD Debug : Enabled

ST-Link enumeration failed

Error in initializing ST-Link device.
Reason: ST-Link DLL error.

emintz
Posts: 12
Joined: Mon Jan 15, 2018 11:22 pm

Re: ST-Link DLL error uploading from Ubuntu 16.0.4 LTE

Postby emintz » Sun Mar 04, 2018 9:14 pm

Changing the network connection from Native to Direct has no effect :(

jxgeoffrey
Posts: 2
Joined: Thu Aug 16, 2018 12:02 pm

Re: ST-Link DLL error uploading from Ubuntu 16.0.4 LTE

Postby jxgeoffrey » Thu Aug 16, 2018 12:09 pm

Hi,
Were you able to fix it? I have the same exact error.

cljdonato
Posts: 2
Joined: Fri May 17, 2019 11:33 pm

Re: ST-Link DLL error uploading from Ubuntu 16.0.4 LTE

Postby cljdonato » Fri May 17, 2019 11:45 pm

I'm also having the same problem.

When I use the NUCLEO-F030R8 demoboard I can debug the code without errors. However, with S-TLINK / V3 it does not work.


Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 2 guests