"Target Not Available" error for "Expressions" variable in Truestudio

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

srihari
Posts: 1
Joined: Sat Jun 15, 2019 1:14 pm

"Target Not Available" error for "Expressions" variable in Truestudio

Postby srihari » Sat Jun 15, 2019 2:14 pm

Hello!

I created a CMSIS C project for running a UART based example which first should display a welcome message in serial emulator(I use Tera Term in windows 10) and should ask for an integer(stored in a variable "opt") and accordingly should display an integer back. I compiled the program and it showed no errors and warnings.

I initially used ST-Link as the debugger for debugging in Truestudio(v 9). I wanted to monitor the value of the variable "opt", so I added it in "expressions" and ran the code. Rather than displaying welcome message, it showed garbage characters and for step 2, I gave values in the emulator. After pausing watch expression I could not see the resultant integer for the value I entered(and Teraterm is not accepting any integer, the screen does not show anything as typed) and rather displayed "Target not Available". I attach the "photo 1" of Truestudio and Teraterm, when running and "photo 2" when I paused the programs to check watch values.

I checked the baud rate, no of data bits and other stuff, all were properly matched.

Please help me how to solve this problem.
You do not have the required permissions to view the files attached to this post.

Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 2 guests