Launch terminated - Failed to fetch device information

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

temp2010
Posts: 3
Joined: Wed Nov 13, 2019 8:14 pm

Launch terminated - Failed to fetch device information

Postby temp2010 » Fri Jul 10, 2020 3:19 pm

I thought nothing had changed, then suddenly everything quit working!

I'm using Windows 10, Atollic TrueSTUDIO for STM32 Version 9.3.0, ST-LINK/V2, and an STM32F105R8T6 on a custom board.

Right now, when I try to launch the debugger, the console window says "Debugger connected", but then a moment later the console window says "Target is not responding, retrying..." and "Vendor = 0x0". I also get a window that pops up with title "Launch terminated" and message "Failed to fetch device information".

There are no funny characters in my login, I'm using all the same setup that I was using last week when everything worked. But now it doesn't.

HERE IS HOW I GOT TO WHERE I AM:

1) A few days ago, I was compiling and debugging just fine.

2) I had **NOT** rebooted my Win10 host computer between then and today, so I doubt a Windows update occurred. Futhermore, I had the same copy of Atollic TrueSTUDIO still running. That is, the only different in today and a few days ago is that time passed. The O/S and the program running are the same invocation.

3) This morning, I switched to a different board and then launched the debugger on it. This launch was the same build that had worked on a different board a few days ago. This time, however, the debugger failed to connect.

4) So I went back to the original board, that was working a couple days ago. It also got the failure to connect the debugger. That's wierd.

5) Well, I've had that failed to connect problem before. So I loaded the STM32 ST-LINK Utility and held the board reset button in combination with erasing the chip while configured to connect while reset. The utility said the chip got erased. I did that to both boards.

6) Then, I tried to debug again from Atollic TrueSTUDIO, using the first known-working board. While the debugger connected at first, I then got this brand new message about "Failed to fetch device information". I tried the other board. Same message. (Note that the other board should be a good board, because it was working a couple of weeks ago, with no known changes made.)

7) Getting this new message and all these unexpected problems, I restarted my Win10 computer, unplugged and replugged the ST-LINK/V2, and power cycled my board. But that didn't help.

8) I am now at a loss to what's wrong. Did my STM32 ST-LINK Utility chip erase do something wrong or incomplete?

Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 1 guest