BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

Andy_Blue
Posts: 14
Joined: Fri May 18, 2018 2:57 pm

BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Postby Andy_Blue » Thu Jan 03, 2019 4:44 am

In TrueStudio 9.2, there is no option to specify the “Target Settings” for BlueNRG-1 or STEVAL-IDB007V1 or V2.

Also there is only STEVAL-IDB008V1 for Boards under BlueNRG-2, what about STEVAL-IDB008V2? I saw a BlueNRG-2-KIT under Boards of BlueNRG-2, should I chose it for STEVAL-IDB008V2?
Thanks,
Andy

Markus Girdland
Posts: 149
Joined: Thu May 11, 2017 11:27 am

Re: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Postby Markus Girdland » Mon Jan 07, 2019 10:33 am

Hello Andy,

BlueNRG-1 doesn't work with TrueSTUDIO 9.0 and newer, you would have to use 8.1 for that.
As for the second part of the question, yes. You should select "BlueNRG-2 -> Boards -> BlueNRG-2-KIT" in the c project creation wizard.

Andy_Blue
Posts: 14
Joined: Fri May 18, 2018 2:57 pm

Re: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Postby Andy_Blue » Mon Jan 07, 2019 8:24 pm

Hi Markus,
Thanks for the replying.
It is considered to be a bug for missing support to BlueNRG-1 in TrueSTUDIO 9.x?
It's pain to have to keep more versions of TrueSTUDIO installed side by side.
Is there a workaround for TrueSTUDIO 9.x? Something like manually configuration/scripting?
The toolchain and GDB server/ debugger driver should not be a problem, so any quick fix available ?
-Andy

Markus Girdland
Posts: 149
Joined: Thu May 11, 2017 11:27 am

Re: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Postby Markus Girdland » Wed Jan 09, 2019 9:31 am

It's not really a bug, the BlueNRG-1 has very different hardware than every other STM32 MCU which has complicated things. But it's something we're still working on.

We have purposefully made the TrueSTUDIO installation not interfere with another installation of TrueSTUDIO in any way, so there shouldn't be any problems having multiple copies of it installed. Although I understand that it would be preferred to only need one copy installed. However, I don't know of any workaround or quick fix.

Andy_Blue
Posts: 14
Joined: Fri May 18, 2018 2:57 pm

Re: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Postby Andy_Blue » Wed Jan 09, 2019 4:41 pm

Thanks for clarifying.
However it comes to a further question, how much difference between the BlueNRG-1 and BlueNRG-2?
By my knowledge, BlueNRG-2 can be considered as an enhanced version of BlueNRG-1, BlueNRG-2 comes with 256 kB of Flash and BlueNRG-1 with 160 kB; BlueNRG-2 comes option for a new QFN48 package type (up to 26 GPIO)
It seems the FR part is little different, but it should no impact the firmware development or they are hidden in the libraries from ST.
So I was wondering why it dropped the support for BlueNRG-1 in TrueStudio 9.2, but kept the support for BlueNRG-2?

-Andy

Markus Girdland
Posts: 149
Joined: Thu May 11, 2017 11:27 am

Re: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Postby Markus Girdland » Tue Feb 12, 2019 3:24 pm

Sorry for the delayed response. Just received another BlueNRG-1 question which made me realize I never answered here.

how much difference between the BlueNRG-1 and BlueNRG-2?

I'm not sure but it's caused some issues with verifying the device.

So I was wondering why it dropped the support for BlueNRG-1 in TrueStudio 9.2, but kept the support for BlueNRG-2?

Hardware differences causing problems with verification. I can't be more specific I'm afraid.


Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 1 guest