Atollic: where to switch off compiler errors for CMSIS

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

k1.ebrahimpour
Posts: 2
Joined: Sat Dec 15, 2018 2:44 pm

Atollic: where to switch off compiler errors for CMSIS

Postby k1.ebrahimpour » Sat Dec 15, 2018 2:50 pm

Hi
I need to switch off some compiler errors from CMSIS (see below for an example)
and can't figure out where I can set/change the compiler settings. I am using GCC
and Atollic 9.1.0

Build Error message:
source/architecture/ARM/ARMv6-M-ARMv7-M/external/CMSIS/core_cm7.h: In function ‘void SCB_InvalidateDCache_by_Addr(uint32_t*, int32_t)’:
source/architecture/ARM/ARMv6-M-ARMv7-M/external/CMSIS/core_cm7.h:2468:34: error: cast from ‘uint32_t* {aka unsigned int*}’ to ‘uint32_t {aka unsigned int}’ loses precision [-fpermissive]
uint32_t op_addr = (uint32_t)addr;


Thanks for any hints
K1

k1.ebrahimpour
Posts: 2
Joined: Sat Dec 15, 2018 2:44 pm

Re: Atollic: where to switch off compiler errors for CMSIS

Postby k1.ebrahimpour » Sat Dec 15, 2018 4:06 pm

This is an imported project and I noticed now that only by imported projects C/C++ Build Setting in the GUI are missing.
I used cmake to generate an eclipse ninja project


Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 1 guest