Debug Session Failed in v9.1 & v9.2

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

kevinwabbit
Posts: 1
Joined: Fri Dec 07, 2018 1:20 am

Debug Session Failed in v9.1 & v9.2

Postby kevinwabbit » Fri Dec 07, 2018 2:09 am

Hello everyone,
There are three different version of TruesSTUDIO installed in my computer.
    TrueSTUDIO for STM32 9.0.0
    TrueSTUDIO for STM32 9.1.0
    TrueSTUDIO for STM32 9.2.0

When I tried to start debugging session on v9.1 and v9.2, it failed.But everything work fine in v9.0.
The error dialog showed by the v9.2 is (I don't know how to post a screen shot :| ):

Title:Launch terminaed
Content:Failed to fetch device information

Title:Embedded C/C++ Application
Content:Failure at line:6 in 'Target Software Startup Scripts'.Please edit the debug configuration settings.
Error finishing flash operation

The debug log showed below:
STMicroelectronics ST-LINK GDB server. Version 5.1.0
Copyright (c) 2018, STMicroelectronics. All rights reserved.

Starting server with the following options:
Persistent Mode : Disabled
Logging Level : 1
Listen Port Number : 61234
Status Refresh Delay : 15s
Verbose Mode : Disabled
SWD Debug : Enabled

Waiting for debugger connection...
Debugger connected
Encountered Error when opening ..\STM32CubeProgrammer\bin\STM32_Programmer_CLI.exe
Error in STM32CubeProgrammer
Encountered a Socket Error, Exiting..
Debugger connection lost.
Shutting down...


I didn't modify the target software startup scripts, it just keep default.
# Set flash parallelism mode to 32, 16, or 8 bit when using STM32 F2/F4 microcontrollers
# 2=32 bit, 1=16 bit and 0=8 bit parallelism mode
monitor flash set_parallelism_mode 2

# Load the program executable
load

# Enable Debug connection in low power modes (DBGMCU->CR)
set *0xE0042004 = (*0xE0042004) | 0x7
# Set a breakpoint at main().
tbreak main

# Run to the breakpoint.
continue


I also installed the STM32CubeProgrammer v1.3.0 GUI interface.It is well connected to ST-Link V2 which firmware version is V2J32S7. The elf file download process is successfully with this standalone CubeProg.

I tried to totally close OS firewall, but nothing change.

I'm going to use v9.0 until this problem fixed.

Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 2 guests