Fresh Installation - No Device List

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

reference
Posts: 9
Joined: Thu Jul 26, 2018 7:52 am

Fresh Installation - No Device List

Postby reference » Fri Nov 09, 2018 4:11 pm

I just installed Atollic in a freshly installed Windows 7 and tried to create a new CMSIS project. The devices list is empty, I can not create a project.

Maybe this is because of the fact that the development computer doesn't have internet access. Is it now required to have internet access to write software? :(
You do not have the required permissions to view the files attached to this post.

DavidPNTech
Posts: 3
Joined: Fri Nov 09, 2018 12:24 am

Re: Fresh Installation - No Device List

Postby DavidPNTech » Tue Nov 13, 2018 11:14 pm

You could download STMXCube somewhere else and the Zip files that provide the device information.
fwiw

Markus Girdland
Posts: 149
Joined: Thu May 11, 2017 11:27 am

Re: Fresh Installation - No Device List

Postby Markus Girdland » Wed Nov 14, 2018 9:24 am

Hello there,

Yes, the first time you try to create a CMSIS project you need Internet to download the package. This is to decrease the size of the TrueSTUDIO installation. If you just want to get started with a project without the use of Internet then an embedded project creation is the way to go.

reference
Posts: 9
Joined: Thu Jul 26, 2018 7:52 am

Re: Fresh Installation - No Device List

Postby reference » Tue Nov 20, 2018 7:29 am

@DavidPNTech

Thanks, but what exactly should I download and where exactly should I extract it?

@Markus Girdland

Thanks, if I may ask for a feature request - instead of silently failing it would be much better to show a warning message with a small manual how to manually download/provide the necessary files to TrueStudio when there is no internet connection or it's not reliable.

Markus Girdland
Posts: 149
Joined: Thu May 11, 2017 11:27 am

Re: Fresh Installation - No Device List

Postby Markus Girdland » Tue Nov 20, 2018 8:50 am

We will discuss the CMSIS implementation soon, I'll be sure to bring it up!

reference
Posts: 9
Joined: Thu Jul 26, 2018 7:52 am

Re: Fresh Installation - No Device List

Postby reference » Mon Nov 26, 2018 3:41 pm

Great, thank you.

orangedwarf
Posts: 2
Joined: Mon Feb 03, 2020 10:46 pm

Re: Fresh Installation - No Device List

Postby orangedwarf » Mon Feb 03, 2020 10:49 pm

I have experienced the same issue. Any help on a link and the required files would be really appreciated.


Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 1 guest