Truestudio will not start

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

svenn
Posts: 2
Joined: Thu Jun 13, 2019 8:42 am

Truestudio will not start

Postby svenn » Thu Jun 13, 2019 10:27 am

Hi,
After an update of Labview 2019 and after an restart the Truestudio V9.3.0 will not launch.

Here is my error log file:
!SESSION 2019-06-13 12:16:30.567 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_181
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2019-06-13 12:16:32.628
!MESSAGE Application error
!STACK 1
java.lang.NoSuchFieldError: url
at org.eclipse.jface.resource.URLImageDescriptor.createImage(URLImageDescriptor.java:258)
at org.eclipse.jface.resource.ImageDescriptor.createImage(ImageDescriptor.java:224)
at org.eclipse.jface.resource.ImageDescriptor.createImage(ImageDescriptor.java:202)
at org.eclipse.ui.internal.Workbench.initializeImages(Workbench.java:1892)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:800)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:160)
at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:173)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:116)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

svenn
Posts: 2
Joined: Thu Jun 13, 2019 8:42 am

Re: Truestudio will not start

Postby svenn » Wed Jun 19, 2019 7:49 am

When starting the Truestudio it terminates with a popup box saying "An error has occurred. Se the log file", and the log file is what you see in the first post.
Now I just figured out that I can start Truestudio if I Run as administrator, and I have to do this every time.

So my question is what have happen and how can I fix it so I don't have to use Run as administrator?


Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 3 guests