Min Free Stack is not updated

Discussions concerning TrueSTUDIO for STM32 9.0.0 and later versions.

Moderators: Markus Girdland, Mattias Norlander

sashir
Posts: 1
Joined: Sun Apr 14, 2019 8:52 am

Min Free Stack is not updated

Postby sashir » Sun Apr 14, 2019 9:38 am

Hello

I'm trying to use FreeRTOS aware debugging, I'm using following software:
Atollic TrueSTUDIO® for STM32, Built on Eclipse Neon.1a. Version: 9.3.0 Build id: 20190212-0734
STM32CubeMX Version 5.1.0
STM32CubeF4 Firmware Package V1.24.0 / 08-February-2019
On Nucleo 64 STM32F446RE

I managed to get Run Time statistics using following tutorial: http://blog.atollic.com/visualizing-run-time-statistics-using-freertos
However Min Free Stack always shows >256 as seen in the picture attached.

I've added following define:
#define INCLUDE_uxTaskGetStackHighWaterMark 1
And I can read stack size manually using uxTaskGetStackHighWaterMark function, but I still get no information in Truestudio

Are there any more settings that I need to add to make it work?
You do not have the required permissions to view the files attached to this post.

rdamon
Posts: 5
Joined: Fri Mar 29, 2019 3:28 pm

Re: Min Free Stack is not updated

Postby rdamon » Mon Apr 15, 2019 7:04 pm

It seems to only report the exact usage if it is less than 256, and >256 if it is over that. I suspect so they don't need to download the full stack from all the tasks.

I tend to put a command into my programs to list the task status of all the tasks to get the exact value at a point in time.


Return to “TrueSTUDIO for STM32 discussions”

Who is online

Users browsing this forum: No registered users and 1 guest