STM32CubeMX for STM32F100RCT MCU generated project in Atollic

Share code examples or discuss embedded software, including device drivers, interrupt handlers, middleware and application code.

Moderators: Markus Girdland, Mats P, Mattias Norlander

Anani
Posts: 2
Joined: Fri Mar 31, 2017 11:46 am

STM32CubeMX for STM32F100RCT MCU generated project in Atollic

Postby Anani » Tue Jun 06, 2017 10:44 am

I am having issues when debugging STM32CubeMX for STM32F100RCT MCU generated project in Atollic. The ST-Link debugger jumps to unknown code location and generated HW fault exception. It happens with Cube generated peripheral INI HAL like TIM16, TIM17 and SPI1 as well. Usually in TIMx cases it happens when tmpcr1=TIMx->CR1; line in HAL {void TIM_Base_SetConfig(TIM_TypeDef *TIMx, TIM_Base_InitTypeDef *Structure)} function is executed. In the SPI1 failure case it happens when __HAL_AFIO_REMAP_SPI1_ENABLE() macro is called. I am using Cube App V4.21, FW V.1.4 and Atollic 7.1.2 Lite. Any idea? Please help.

Anani
Posts: 2
Joined: Fri Mar 31, 2017 11:46 am

Re: STM32CubeMX for STM32F100RCT MCU generated project in Atollic

Postby Anani » Thu Jun 08, 2017 8:53 am

Hi All, in the case of ST-Link freezing when __HAL_AFIO_REMAP_SPI1_ENABLE() macro is called:
The error message is:
warning: Remote failure reply: E31
Remote failure reply: E31
As a matter of fact the re-map of SPI1 affect AFIO-MAPR register where SWD re-mapping bits are located as well.
Could that be the problem?

frank_ee
Posts: 36
Joined: Wed Apr 05, 2017 5:08 pm
Location: USA

Re: STM32CubeMX for STM32F100RCT MCU generated project in Atollic

Postby frank_ee » Wed Aug 30, 2017 10:38 pm

Hello,

Is your clock speed for the MCU properly setup?


Return to “Embedded target code development discussions”

Who is online

Users browsing this forum: No registered users and 1 guest