invocation of headless.bat doesn't return but hangs

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

Posts: 1
Joined: Tue May 05, 2020 10:28 pm

invocation of headless.bat doesn't return but hangs

Postby anelson327 » Tue May 05, 2020 10:51 pm

I can build my project from the TrueStudio v9.3.0 IDE just fine; the workspace is set to C:\Projects\G3, and that is where the .metadata file created by the IDE is located.

I am performing these steps to automate this build using TrueStudio v9.3.0 on Windows 10 v1809 in cmd.exe:

1. cd to "C:\Program Files (x86)\Atollic\TrueSTUDIO for STM32 9.3.0\ide"
2. execute this command from the command prompt: "headless.bat -data C:\Projects\G3 -cleanBuild G3_Alpha"
3. this performs the build without issue in the same way it builds in the IDE.
4. PROBLEM: the command doesn't terminate -- I have to use <ctrl>C to get a command prompt back. This means that when I invoke it in a batch file, it hangs at that point. I've tried invoking "TrueSTUDIOc.exe --launcher.suppressErrors -nosplash -application org.eclipse.cdt.managedbuilder.core.headlessbuild -data C:\Projects\G3 -cleanBuild G3_Alpha" (which is what the headless.bat script does) but it also hangs in the same way.

I've tried running cmd.exe as Administrator or not, it hangs either way. I'm stuck -- can't automate my builds with this problem!

Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 5 guests