ST-Link debug not working

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

gorillagrunt
Posts: 3
Joined: Sat Jan 19, 2019 8:39 pm

Re: ST-Link debug not working

Postby gorillagrunt » Mon Jan 21, 2019 6:26 pm

I have instead the following problem:
failing to bing to port 61234, error code -1:Result too large
failure starting GDB Server: TCP Port 61234 not available
GDB Server exited

Could please someone help me??
Drivers are up to date and firewall is allowing the gdbserver

hazem
Posts: 1
Joined: Wed Jan 30, 2019 12:17 pm

Re: ST-Link debug not working

Postby hazem » Wed Jan 30, 2019 2:41 pm

sztefano wrote:Hi,

I'm using recent Atollic Lite version (5.4). I've got some problems with stm32 discovery/nucleo boards (i've checked on stm32f0 and stm32f411) and ST-Link debug probe:

Atollic TrueSTUDIO gdbserver for ST-Link. Version 2.2.0 Pro
Copyright 2010-2015, Atollic AB.


Starting server with the following options:
Persistant Mode : Disabled
LogFile Name : debug_log.txt
Logging Level : 1
Listen Port Number : 61234
Status Refresh Delay : 15s
Verbose Mode : Disabled
SWD Debug : Enabled

Connecting to the ST-Link Debugger... OK
Waiting for debugger connection...

And nothing more happens. I haven't got any virtual drives in my computer.I've tried also disabling firewall etc. I'm running win7 64bit, ST-Link with upgraded firmware.
Any hints what could be wrong ?


this issue may be in different things that you can check as follows
1-check the option bytes you may be disabled the SWD communication by accident
2-check the debug configuration as autostart local GDB server and SWD interface
3-check the wiring :oops:

gorillagrunt
Posts: 3
Joined: Sat Jan 19, 2019 8:39 pm

Re: ST-Link debug not working

Postby gorillagrunt » Sun Feb 03, 2019 1:28 pm

Thanks a lot,
i have checked the flags and the wiring.
Actually if I launch Run->Debug something happens but it too fast, when I go on the debug configuration and then launch the debugging everything starts to work, is going on the debug perspective but it stops at 96% and it doesn't go further.

I've tried with the STLink Utility, and at least it is possible to connect to the board.

No idea on what is wrong!
Thanks a lot


Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 2 guests