Error in initializing ST-Link device.

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

hayes
Posts: 1
Joined: Fri Jan 31, 2020 11:47 pm

Error in initializing ST-Link device.

Postby hayes » Sat Feb 01, 2020 12:13 am

hello everyone,
I am using the STM32f407vg
i am a new atollic user.I used it for 3 week without any problems.I am currently receiving an error during the debugging process.

Code: Select all

Error in initializing ST-Link device.
Reason: (-1) Unknown. Please check power and cabling to target.

and

Code: Select all

STMicroelectronics ST-LINK GDB server. Version 5.1.0
Copyright (c) 2018, STMicroelectronics. All rights reserved.

Starting server with the following options:
        Persistent Mode            : Disabled
        Logging Level              : 1
        Listen Port Number         : 61234
        Status Refresh Delay       : 15s
        Verbose Mode               : Disabled
        SWD Debug                  : Enabled

Failed to bind to port 61234, error code -1: Result too large
Failure starting GDB server: TCP port 61234 not available.


Image


I try everyhing.
1)Stlink Upgrade.
2)I cleaned it with ST-LINK Utility.
3)I got used to it directly.(Network connection)
4)Use Specific ST-link
5)Old STLinkUSBDriver.dll
Physical
I tried another Cable and stm32f407vg.

But it still continues to fail.

I am a university student and I have a project to be completed, please help.

I like TrueSTUDIO and I want to continue using it.

Thanks to those who gave advice.

Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 1 guest