arm-atollic-eabi-gdb --version Cannot run program "C:\Program": Launching failed

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

kishore.kedari
Posts: 2
Joined: Fri Sep 06, 2019 6:23 am

arm-atollic-eabi-gdb --version Cannot run program "C:\Program": Launching failed

Postby kishore.kedari » Fri Sep 06, 2019 6:43 am

Hi,
We have a problem with debugging our application in Atollic TrueSTUDIO.
Board: NUCLEO-L476RG

DEBUG ERROR.png


We are getting the following error
error.png


So we tried running the following command via CLI and able to execute the same:
"arm-atollic-eabi-gdb --version"
cmd.JPG


Help us if any other special settings are necessary for the same to work .
You do not have the required permissions to view the files attached to this post.

frank_ee
Posts: 111
Joined: Wed Apr 05, 2017 5:08 pm
Location: USA

Re: arm-atollic-eabi-gdb --version Cannot run program "C:\Program": Launching failed

Postby frank_ee » Tue Sep 10, 2019 5:35 pm

Hello,

Is this the first time this problem occurred? Are the debug settings correct?

kishore.kedari
Posts: 2
Joined: Fri Sep 06, 2019 6:23 am

Re: arm-atollic-eabi-gdb --version Cannot run program "C:\Program": Launching failed

Postby kishore.kedari » Wed Sep 11, 2019 7:31 am

This error is persistent. We checked debugger settings which are default.
I tried uninstalling and installing Atollic true studio with admin rights as well.


Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 1 guest