Atollic Crashing on program start

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

hackster84
Posts: 2
Joined: Tue May 24, 2016 12:11 pm

Atollic Crashing on program start

Postby hackster84 » Wed Aug 14, 2019 10:28 pm

Hello,

I'm using Atollic 8.1.0 and have a full pro license running on Windows 7. I am using it with Silicon Labs based processors, which is why I haven't upgraded to the newest versions of Atollic. Unfortunately, the ST micro line of processors doesn't have what my company needs in the way of features and we had already designed an entire product line around the Silicon Labs products when ST bought Atollic. That is besides the point.

There was an extended power outage at my building over the weekend and the UPS attached to my computer apparently didn't have enough juice (another problem I have to fix) to put the computer into hibernate mode correctly while my Atollic workspace was open. Now, when I try to launch the program, the first thing I get immediately after the initial splash screen is displayed is an error (attached). I don't even get the choice of what workspace I want to open up. The error dialog tells me to view a log (text below) which appears to have a java error in it caused by an array out of bounds exception.

I'm wondering if there's any way that I can clear some basic program settings to remove the error and get my environment up and running without uninstalling the IDE and reinstalling it. I don't want to have to go through the exercise of getting everything installed and set up properly again since the customizations took a while to get right, especially when there's no guarantee that a full uninstall and reinstall would actually do anything to fix the problem.

Any help is appreciated. Thanks in advance.

-Chris


!SESSION 2019-08-14 14:54:47.234 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_121
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2019-08-14 14:54:48.688
!MESSAGE Application error
!STACK 1
java.lang.ArrayIndexOutOfBoundsException
at java.lang.System.arraycopy(Native Method)
at java.util.Arrays.copyOfRange(Arrays.java:3485)
at java.util.Arrays.copyOfRange(Arrays.java:3441)
at org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.lambda$7(ChooseWorkspaceDialog.java:380)
at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:193)
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(ArrayList.java:1374)
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:481)
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:471)
at java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:708)
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
at java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:499)
at org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.createUniqueWorkspaceNameMap(ChooseWorkspaceDialog.java:382)
at org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.createRecentWorkspacesComposite(ChooseWorkspaceDialog.java:325)
at org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.createDialogArea(ChooseWorkspaceDialog.java:176)
at org.eclipse.jface.dialogs.TitleAreaDialog.createContents(TitleAreaDialog.java:158)
at org.eclipse.jface.window.Window.create(Window.java:426)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1095)
at org.eclipse.jface.window.Window.open(Window.java:783)
at org.eclipse.ui.internal.ide.ChooseWorkspaceDialog.prompt(ChooseWorkspaceDialog.java:114)
at org.eclipse.ui.internal.ide.application.IDEApplication.promptForWorkspace(IDEApplication.java:346)
at org.eclipse.ui.internal.ide.application.IDEApplication.checkInstanceLocation(IDEApplication.java:265)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:132)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
You do not have the required permissions to view the files attached to this post.

Mattias Norlander
Posts: 273
Joined: Fri Apr 29, 2016 10:01 am

Re: Atollic Crashing on program start

Postby Mattias Norlander » Wed Aug 21, 2019 12:31 pm

Sorry to hear about the power loss and the implications of this event.
As you say, no guarantee it will work after reinstallation.
But unless you have installed plenty of Eclipse plug-ins there should not be a lot of re-configuration of the tool itself since almost all settings are stored in the workspace metadata. And you will certainly not delete the workspace.

Did you get up n running again?

hackster84
Posts: 2
Joined: Tue May 24, 2016 12:11 pm

Re: Atollic Crashing on program start

Postby hackster84 » Tue Aug 27, 2019 5:04 pm

I was able to get the workspace up and running again by having the program re-create the org.eclipse.ui.ide.prefs file found in C:\Users\<username>\.eclipse\com.atollic....pro_8.1.0...\configuration\.settings. Apparently this is what got corrupted and renaming it to org.eclipse.ui.ide.prefs.old forced the recreation of the file.

I actually do have several Eclipse add-ons and I wanted to mantain the library of git repositories that I had access to through the interface, so that was really the holdup.

Anyway, I'm back up and running. Thank you for checking in and I hope this helps anyone else who has a similar issue with their IDE.

pintoharlan
Posts: 1
Joined: Tue Oct 22, 2019 8:00 am

Re: Atollic Crashing on program start

Postby pintoharlan » Tue Oct 22, 2019 8:02 am

I have a similar issue with my IDE. Thanks for the solution.
spanish dictionary


Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 2 guests