STM32 ST-Link Utility Can not connect to target!

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

Posts: 2
Joined: Mon Nov 12, 2018 4:01 am

STM32 ST-Link Utility Can not connect to target!

Postby cdmech » Mon Nov 12, 2018 6:36 pm

Hello STM enthusiasts,

I am reaching out as I am having a puzzling issue with connecting to my STM32 chip with an ST-LINK V2.

What I have for a set up is:
OS: Windows 10 x64 bit
IDE: Atollic TrueStudio v9.1.0
Debugger/Programmer: ST-LINK V2 (clone)
Chip: STM32F030R8T6 (ARM core M0)

My chip is soldered onto a breakout board, which I got from Nothing else is on the board, just the chip and easy access to the pins.

I am trying to run a simple test program to blink an LED, but I am running into the “Can not Connect to Target Error”.

This error comes up in TrueStudio and the STM32 ST-LINK Utility.
Pictures from the error in both environments are attached.

I have checked the physical cabling as well as the ST-Link dongle. Both seem fine. The ST-Link LED lights up. It blinks blue when it tries to connect and turns orange when it fails to connect. Connections are made to the correct pins from the dongle to the chip: SWCLK, SWDIO, 3.3v and GND. I can also confirm that power is getting to the chip.

In the STM32 ST-LINK Utility I have tried to update the firmware (picture attached), which seemed to update alright, but did not solve the issue. The error message in STM32 ST-LINK Utility (picture attached) suggests trying different configuration of settings under the target menu. I have tried many different configurations, but with no success (picture of settings window attached).

The chip may be bricked, so I have tried to do the following:
-Set BOOT0 high and get the device to boot into System Loader mode and erase it. This still gave me the cannot connect to target error.
-Full chip erase in STM32 ST-LINK Utility with reset output set (high and low). Again, the same error.

One thing I am worried about is about the ST Link under Windows device manager (picture attached). Messages appear such as: “device install requested” “device not migrated” and “device requires further installation”.
I have installed, uninstalled and re-installed the newest drivers: STSW-LINK009. When I read the data brief on this it says: “The driver must be installed prior to connecting the device, in order to have a successful enumeration.” The first time I installed, the device (ST link dongle), was definitely connected. So, I uninstalled and re-installed with the device disconnected before connecting again.

Unfortunately, all of my troubleshooting attempts have been in vain and I am at a loss now. If there is in fact a driver installation issue as the device manager suggests, then unfortunately I have run out of ideas to fix it. If it is something else causing the issue, then again, I cannot figure it out… If anyone can shed some light on this, I would really appreciate it!

Thank you!
You do not have the required permissions to view the files attached to this post.

Markus Girdland
Posts: 149
Joined: Thu May 11, 2017 11:27 am

Re: STM32 ST-Link Utility Can not connect to target!

Postby Markus Girdland » Wed Nov 14, 2018 9:16 am

Hello there,

I don't have any good clue for you, I'm afraid.
However, I would suggest that you try your luck over at the ST forums as they probably have a great deal more experience with ST-Link Utility than we do at this forum. You could also perhaps try with CubeProgrammer to see if it's the same thing and if so, post in their forums as well.

Good luck!

Posts: 2
Joined: Mon Nov 12, 2018 4:01 am

Re: STM32 ST-Link Utility Can not connect to target!

Postby cdmech » Thu Nov 15, 2018 7:25 pm

Hi Markus,

Thank you for taking the time to reply! I appreciate you pointing me to the ST forum. As you suggest, I will try my luck there and look into CubeProgrammer as well.

All the best.

Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 2 guests