Flashing nucleo board

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

beerbiceps
Posts: 1
Joined: Thu May 03, 2018 8:30 am

Flashing nucleo board

Postby beerbiceps » Fri May 04, 2018 6:14 am

Hi,
I recently got to know about TrueSTUDIO and started working on it, So i'm totally a rookie. I have a Nucleo-L152RE board and I'm not able to flash the controller. When I enter the Debug mode, the current program does executes but it is not downloaded in the controller. I changed the startup script in Debug configuration menu as below, but I suppose the flashing had some error because the communication led turns RED after showing - flashing done - in console.

# Set flash parallelism mode to 32, 16, or 8 bit when using STM32 F2/F4 microcontrollers
# Uncomment next line, 2=32 bit, 1=16 bit and 0=8 bit parallelism mode
#monitor flash set_parallelism_mode 2

# Set character encoding
set host-charset CP1252
set target-charset CP1252

# Reset to known state
monitor reset

# Load the program executable
load

quit

Can anyone please suggest a way to flash my controller??

Sorry for such a basic question but right now its the most cumbersome one.
Any help is greatly appreciated. :)

varani
Posts: 1
Joined: Mon Dec 10, 2018 7:43 pm

Re: Flashing nucleo board

Postby varani » Mon Dec 10, 2018 7:50 pm

Have you try to uncommenct the row:

monitor flash set_parallelism_mode 2


?


Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 1 guest