ERROR : Launching has encountered problem

Discuss how to use the features of Atollic TrueSTUDIO, including the editor, assembler, C/C++ compiler, linker, debugger, static code analysis and team collaboration tools.

Moderators: Markus Girdland, Mattias Norlander

subramaniantr
Posts: 2
Joined: Tue Aug 13, 2019 7:25 pm

ERROR : Launching has encountered problem

Postby subramaniantr » Tue Aug 13, 2019 7:48 pm

I get this error on a MsgBox saying : 'Launching a_gpio_test ' has encountered a problem

Clicking Details shows the below

Error starting process.
Cannot run program "C:\VIVEK\STM32\WORKSPACE\a_gpio_test\Debug\a_gpio_test.elf": Launching failed
Cannot run program "C:\VIVEK\STM32\WORKSPACE\a_gpio_test\Debug\a_gpio_test.elf": Launching failed
Cannot run program "C:\VIVEK\STM32\WORKSPACE\a_gpio_test\Debug\a_gpio_test.elf": Launching failed

The program works fine for debug mode. If I go to debug mode and click play buttong, it does program my board stm32F discovery Board.

subramaniantr
Posts: 2
Joined: Tue Aug 13, 2019 7:25 pm

Re: ERROR : Launching has encountered problem

Postby subramaniantr » Wed Aug 14, 2019 8:59 pm

looks like Keil is the only reliable tool which works even though it doesn't have fancy tool setup. Both stm32 cube ide and atollic studio have failed to provide any support. No doubt the latter look sophisticated and more advanced, but what use going to a restaurant which has 3000 items in its menu, but no food.

Mattias Norlander
Posts: 273
Joined: Fri Apr 29, 2016 10:01 am

Re: ERROR : Launching has encountered problem

Postby Mattias Norlander » Wed Aug 21, 2019 12:33 pm

Could this be low-power issue? Does your application go into some low-power mode after booting without enabling low-power debug?


Return to “Atollic TrueSTUDIO tool discussions”

Who is online

Users browsing this forum: No registered users and 8 guests