Search found 149 matches

by Markus Girdland
Wed Nov 14, 2018 9:22 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Information Center does not appear Version: 9.1.0
Replies: 2
Views: 266

Re: Information Center does not appear Version: 9.1.0

Hello there,

Make sure there's nothing blocking access for TrueSTUDIO, such as anti-virus, firewall etc.
I see that the installation on the laptop worked fine but if you're looking for any resources you can't find let me know.
by Markus Girdland
Wed Nov 14, 2018 9:16 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: STM32 ST-Link Utility Can not connect to target!
Replies: 2
Views: 2020

Re: STM32 ST-Link Utility Can not connect to target!

Hello there, I don't have any good clue for you, I'm afraid. However, I would suggest that you try your luck over at the ST forums as they probably have a great deal more experience with ST-Link Utility than we do at this forum. You could also perhaps try with CubeProgrammer to see if it's the same ...
by Markus Girdland
Wed Nov 14, 2018 9:03 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Failure at line 13
Replies: 39
Views: 5764

Re: Failure at line 13

Is here any option to force ST-LINK/V1 to work? Maybe some changes in configuration needed to play with V1? Or my board should be scrapped?:D In 9.1 we don't support v1 anymore because we're using CubeProgrammer for the flash operation but you can still use version 9.0.1 if you're using an ST-Link ...
by Markus Girdland
Tue Nov 13, 2018 2:48 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Failure at line 13
Replies: 39
Views: 5764

Re: Failure at line 13

Is there any way to trigger it from within the startup script or shall I just run it within the post compilation step within Build Steps There's no way to do it inside the startup script. I can flash this way too. but this not a way I like. so let me explain the procedure so then you can reproduce ...
by Markus Girdland
Mon Nov 12, 2018 1:41 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Failure at line 13
Replies: 39
Views: 5764

Re: Failure at line 13

Hi, We are not able to reproduce this problem. It seems as if the common denominator is a failing flash operation (the load command). There are several reasons as to why a load operation can fail. Let's try to isolate the problem. If you have this problem then please try to run STM32CubeProgrammer s...
by Markus Girdland
Mon Nov 05, 2018 10:15 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: CubeMX projects using TrueSTUDIO
Replies: 2
Views: 323

Re: CubeMX projects using TrueSTUDIO

Hello rentron,

I'm pretty sure there's no way to change it.
We're working closely with the CubeMX team to make it smoother, though.
Until then, you will need to set the optimization level manually for each project you generate.
by Markus Girdland
Mon Nov 05, 2018 10:14 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Unable to download example projects from truestudio IDE
Replies: 1
Views: 200

Re: Unable to download example projects from truestudio IDE

Hello Mallesh,

What version are you using?
I tried it on 9.1 and 9.0.1 and it seems to work for me.

Make sure you don't have an anti-virus/firewall or something else blocking connection for TrueSTUDIO.
by Markus Girdland
Fri Nov 02, 2018 9:25 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Will STM32CubeMX ever be able to target atollic directly?
Replies: 3
Views: 395

Re: Will STM32CubeMX ever be able to target atollic directly?

Hello,

I'm using stand-alone CubeMX version 4.26.1 and there we are a target.
Perhaps you're using an outdated version?
by Markus Girdland
Fri Nov 02, 2018 9:23 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Is there autocomplete as you type?
Replies: 2
Views: 678

Re: Is there autocomplete as you type?

Hello,

The content assist is default to ctrl + space but you can change this.
[Window -> Preferences -> General -> Keys] and then search for content assist and bind it to what you want.
by Markus Girdland
Fri Nov 02, 2018 9:22 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Support for STM32WB55?
Replies: 2
Views: 311

Re: Support for STM32WB55?

Hello xdiz,

Eventually we will have support for it.
I can't give a specific time frame, though.

Go to advanced search