Search found 5 matches

by bertrand
Fri Jan 18, 2019 2:32 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Failure at line 13
Replies: 39
Views: 6054

Re: Failure at line 13

For information I had the same issue by using a ST-Link V2 after using a ST-Link V3.
I used the Legacy JTAG of the ST-Link V3 to be like a ST-Link V2 and all is running fine.

From now, I have to switch to V3 in any case.

Bertrand
by bertrand
Wed Mar 14, 2018 9:05 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Best Method for Bitwise Rotate?
Replies: 13
Views: 1003

Re: Best Method for Bitwise Rotate?

Do you think something different than a simple << or >> ?
by bertrand
Tue Mar 13, 2018 7:33 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: CubeMX delete my code
Replies: 1
Views: 532

Re: CubeMX delete my code

You should write your code between balise like that:
/* USER CODE BEGIN 0 */

/* USER CODE END 0 */

All code between 2 sections is removed.

Bertrand
by bertrand
Mon Feb 26, 2018 9:28 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: Can't restart debugger without reloading code
Replies: 30
Views: 3412

Re: Can't restart debugger without reloading code

Ok, I am a new user of TrueStudio. I worked with openstm32 before. I had not this behaviour with openstm32. So, maybe it could be a configuration problem with Turestudio.
Bertrand
by bertrand
Sun Feb 25, 2018 2:25 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: Can't restart debugger without reloading code
Replies: 30
Views: 3412

Re: Can't restart debugger without reloading code

Hello, I have similar problem, but despite information given in previous post I am not able to solve my problem. When I enter in debug mode for the first time all work fine, but if I "restart", I fall in NVIC infinite routine after I enable it ( HAL_NVIC_EnableIRQ(DMA1_Channel1_IRQn) becau...

Go to advanced search