Search found 46 matches

by DD4DA
Sun Apr 21, 2019 1:57 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Can't debug code
Replies: 6
Views: 1191

Re: Can't debug code

try winIDEA OPEN
by DD4DA
Sat Apr 20, 2019 10:36 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Run vs debug configuration
Replies: 7
Views: 853

Re: Run vs debug configuration

If you find a usable solution, let me know this. I also want to have such one too.
by DD4DA
Sat Apr 20, 2019 10:25 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: arm-atollic-eabi-gcc No such file or directory but file is in place
Replies: 3
Views: 1612

Re: arm-atollic-eabi-gcc No such file or directory but file is in place

arm-atollic-eabi-gcc: error: ..\..\..\..\..\..\..\..\Drivers\CMSIS\Device\ST\STM32L0xx\Source\Templates\system_stm32l0xx.c: No such file or directory arm-atollic-eabi-gcc: fatal error: no input files You use a TEMPLATE and should copy the file to a work Directory. Then exclude the template Directory...
by DD4DA
Sat Apr 20, 2019 10:17 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: TrueStudio for OSX
Replies: 46
Views: 12481

Re: TrueStudio for OSX

I understand that the Mac user are happy to get an IDE for their alien. I don't understand why using eclipse should be an advantage? This IDE is developed by concept for Java developing, not for C/C++ and not for an embedded developing. It's very overloaded and unefficient. It's yould be a good idea...
by DD4DA
Sat Apr 20, 2019 10:10 pm
Forum: Embedded target code development discussions
Topic: code manual
Replies: 12
Views: 2305

Re: code manual

Well, i was not lucky with Atollic TrueStudio, yet. In an eclipse environment, many unusable menu's, option's are available and make the IDE noch very efficent uns the usage. I am also unlucky with the implementation of the gdb interfacing. Why is their not an Option configured for just an upload Fi...
by DD4DA
Sat Apr 20, 2019 9:52 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: SWD speed - STLINK-V3
Replies: 7
Views: 1272

Re: SWD speed - STLINK-V3

Even a half years is passed and None solution was found, i want to spend some notice about the ST-Link. Several years ago, i did some experiences with external Debuggers like them from Keil and Segger. I got the first ST-Discovery boards with the on-board jtag Debugger - the ST-Link. After a few Hou...
by DD4DA
Mon Jan 14, 2019 1:02 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: using (s)printf with float / double
Replies: 8
Views: 9158

Re: using (s)printf with float / double

the linker should inludes the flag -lm
by DD4DA
Sun Jan 06, 2019 9:52 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Debug Session Failed in v9.1 & v9.2
Replies: 10
Views: 2857

Re: Debug Session Failed in v9.1 & v9.2

I did the same experiences with 9.1 and 9.2. The issue must be in the support Code who atollic build-into the eclipse to do the communication between the cdt and atollic processes. The Code that is produced by the toolchain seems to be ok. Seggers Ozone works Pretty in combination of j-link. In addi...
by DD4DA
Sat Dec 08, 2018 8:05 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Bug when first time click on Terminate & Restart button
Replies: 1
Views: 216

Re: Bug when first time click on Terminate & Restart button

This behavior is similar here too, but this happens everytime - the entire link to the jtag/swd seems to be lost, if the first breakpoint is passed.
by DD4DA
Sat Dec 08, 2018 8:02 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: Can't restart debugger without reloading code
Replies: 30
Views: 3668

Re: Can't restart debugger without reloading code

I can not belive it - the issue of Debugging i reported for 9.1.0 is left in 9.2.0 too. Nothing is fixed. In the meantime i had checked the issues and behavior by using a different arm toolchain and Nothing is changed. As a reverse test to find out the responsibility of the issues, i had configured ...

Go to advanced search