Search found 143 matches

by Markus Girdland
Tue Feb 12, 2019 3:26 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: debug with ST-LINK on BlueNRG-1
Replies: 6
Views: 34

Re: debug with ST-LINK on BlueNRG-1

There were some hardware issues which caused some regression, I guess you could say.
As I've said we're hoping to get support for it back but it hasn't been very prioritized so far.
by Markus Girdland
Tue Feb 12, 2019 3:24 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2
Replies: 5
Views: 96

Re: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

Sorry for the delayed response. Just received another BlueNRG-1 question which made me realize I never answered here. how much difference between the BlueNRG-1 and BlueNRG-2? I'm not sure but it's caused some issues with verifying the device. So I was wondering why it dropped the support for BlueNRG...
by Markus Girdland
Tue Feb 12, 2019 2:46 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: debug with ST-LINK on BlueNRG-1
Replies: 6
Views: 34

Re: debug with ST-LINK on BlueNRG-1

I'm not 100% sure, you should be able to build with TrueSTUDIO but I don't know how ST-Link Utility responds to the BlueNRG-1.
You can also use the lite version of the 8.1.0 version, that still works.
by Markus Girdland
Tue Feb 12, 2019 2:07 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Enable to link C++ project autogenerated by CubeMX
Replies: 2
Views: 29

Re: Enable to link C++ project autogenerated by CubeMX

Make sure you go into your projects properties -> C/C++ Build -> Settings -> Tool Settings and copy your C Linkers settings (from Libraries for example) to the corresponding settings of the C++ settings. Also go to C/C++ General -> Paths and Symbols. Make sure to check the includes and symbols tab t...
by Markus Girdland
Tue Feb 12, 2019 1:51 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: debug with ST-LINK on BlueNRG-1
Replies: 6
Views: 34

Re: debug with ST-LINK on BlueNRG-1

Hello,

The BlueNRG-1 does not work with TrueSTUDIO at the moment. It's something that we have been trying to solve and continue to try to do so but so far we have not been able to make it work with TrueSTUDIO just yet.
by Markus Girdland
Wed Jan 16, 2019 9:30 am
Forum: TrueSTUDIO for STM32 discussions
Topic: C++17 & newer Eclipse CDT for Atollic?
Replies: 1
Views: 78

Re: C++17 & newer Eclipse CDT for Atollic?

I don't have any specific plan that I can share at the moment.
There are plans, I just can't say for sure when it would be.
by Markus Girdland
Wed Jan 16, 2019 9:13 am
Forum: TrueSTUDIO for STM32 discussions
Topic: Debug Session Failed in v9.1 & v9.2
Replies: 10
Views: 431

Re: Debug Session Failed in v9.1 & v9.2

I have made a ticket about it, this seems to affect more than just CubeProgrammer. In the meantime you will most likely need to create a new user with English characters.
by Markus Girdland
Tue Jan 15, 2019 1:07 pm
Forum: TrueSTUDIO for STM32 discussions
Topic: Debug Session Failed in v9.1 & v9.2
Replies: 10
Views: 431

Re: Debug Session Failed in v9.1 & v9.2

So the C:\Users\kevin\ is something else instead of 'kevin'? After your report that it's the non-English characters that's the problem I've done some testing and it seems to be a problem in multiple STM32 tools so I'm going to write a ticket about it. Could you tell me what encoding you used in your...
by Markus Girdland
Wed Jan 09, 2019 9:34 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: Debug issues with SWV in STM32 target
Replies: 3
Views: 95

Re: Debug issues with SWV in STM32 target

I'm no expert on the differences or similarities between the two. I'm sure there are some but for the most part it's pretty similar in my opinion. If you can't open the information center you can still find the user guide here: http://gotland.atollic.com/resources/manuals/9.0.0/Atollic_TrueSTUDIO_fo...
by Markus Girdland
Wed Jan 09, 2019 9:31 am
Forum: TrueSTUDIO for STM32 discussions
Topic: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2
Replies: 5
Views: 96

Re: BlueNRG-1 was missing from Target Settings selection on TrueStudio 9.2

It's not really a bug, the BlueNRG-1 has very different hardware than every other STM32 MCU which has complicated things. But it's something we're still working on. We have purposefully made the TrueSTUDIO installation not interfere with another installation of TrueSTUDIO in any way, so there should...

Go to advanced search