Search found 5 matches

by piotr
Thu Feb 16, 2017 4:22 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: Problem with linking static libraries and build system
Replies: 8
Views: 4533

Re: Problem with linking static libraries and build system

When I change e.g. C++ standard in Tool Settings -> C++ Compiler -> General, it is preserved. Looks like the issue concerns only 'Target' section...
by piotr
Tue Feb 14, 2017 9:50 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: Problem with linking static libraries and build system
Replies: 8
Views: 4533

Re: Problem with linking static libraries and build system

Thanks, it works now! It was the missing -c switch so the linking was carried out too soon. That switch was probably deleted unintentionally during migration. I created new projects in TrueSTUDIO and modified some settings. However now I encountered another problem. When I change setting in 'Project...
by piotr
Mon Feb 13, 2017 5:29 pm
Forum: Atollic TrueSTUDIO tool discussions
Topic: Problem with linking static libraries and build system
Replies: 8
Views: 4533

Re: Problem with linking static libraries and build system

Do you have any insights?

This linking issue prevents me from using Atollic TrueStudio.

Thank you,
Piotr
by piotr
Wed Feb 08, 2017 9:07 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: Problem with linking static libraries and build system
Replies: 8
Views: 4533

Re: Problem with linking static libraries and build system

Hi Mattias, Thanks for your response. Below log and linker details. Build log: 09:39:06 **** Incremental Build of configuration Debug for project stm32f7_main **** Info: Internal Builder is used for build arm-atollic-eabi-g++ -mthumb -mcpu=cortex-m7 -mfloat-abi=hard -mfpu=fpv5-sp-d16 -std=c++11 -IC:...
by piotr
Fri Feb 03, 2017 10:43 am
Forum: Atollic TrueSTUDIO tool discussions
Topic: Problem with linking static libraries and build system
Replies: 8
Views: 4533

Problem with linking static libraries and build system

Hello, I decided to migrate my projects from System Workbench to Atollic 7.1.0 and have problems with build system: 1) Linker problem: My main application uses static libraries, that are built as other projects in the same workspace. In project properties, all dependencies, libraries and library pat...

Go to advanced search